Start a new topic

Download stuck on Microsoft store (Only xodo pdf)

Yesterday, I accidentally removed the XODO pdf from my computer. Since then I have been trying to download it from the Microsoft store but the download process is stuck on 1%. I have tried downloading other apps and they worked fine. I have tried resetting Microsoft Store, restarting my PC, etc. But nothing is working. Can anyone help me resolve this issue or provide me an appx file of the latest version? It's an urgent situation!

1 Comment

Hello Rakibul,

Thank you for contacting us. Sorry to hear of the trouble. 


We (Xodo) have absolutely no control or access to the Microsoft App Store. However, a quick google search returns many articles on the subject. Here is one such article that may be of use:

Fix: Microsoft Store App Stuck on Starting Download


If still having trouble, please contact Microsoft app store directly for further help. 

Let us know how it goes! 

Regards,

Xodo Support




Login or Signup to post a comment